Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5

Kompilacja tfs 0.3.7
#1

Witam, 
Mam problem z kompilacja tfs 0.3.6.7 pod jlienta 8.6
Repository ktore sa na *****zie sa nieaktualne a w zources mojego silnika nie ma plikow cmake ani cmakelists.txt wiec odpada nowa metoda przez githuba.
apt-get install subversion autoconf build-essential pkg-config libboost-dev libgmp3-dev libxml2-dev liblua5.1-0-dev libmysqlclient-dev ccache libboost-filesystem-dev libboost-regex-dev libboost-system-dev libboost-thread-dev screen libssl-dev libcrypto++-dev

Ta komenda nie dziala bo nie m
Potrafi znalezc plikow.. 
Prosze o pomocSad
Odpowiedz
#2

Zmień Silnik na normalny:
https://feru.net.pl/showthread.php?tid=118

Przekompiluj:
https://feru.net.pl/showthread.php?tid=4
Odpowiedz
#3

Siemanko, próbowałem zrobić kompilacje na serwerze od użytkownika Fireelemental, który zapodałeś. 
Niestety wysypało milion błędów w konsoli, ale dla odmiany spróbowałem skompilować ten mój serwer metodą, którą podałeś w poradniku i o dziwo szło bezbłędnie do jednego momentu..
Zapodaję linka do screena z błędów w wierszu poleceń:
https://zapodaj.net/fdc70597c0ea6.png.html

Dzięki za zainteresowanie tematem!
Pozdrawiam
Odpowiedz
#4

Jakaś mądra Linuxowa głowa musi się wypowiedzieć.
Jaki masz system zainstalowany?
Odpowiedz
#5

Mam debiana9 ale moge zmienic na inny. Jaki uzywasz?
Tu prawdopodobnie jest problem z biblioteczkami opensl i moze na innym systemie to przejdzie.
Odpowiedz
#6

Ubuntu 18.04 polecam. 0 problemów.
Odpowiedz
#7

(04-14-2020, 02:41 PM)Luiz napisał(a):  Ubuntu 18.04 polecam. 0 problemów.
Ten sam system co ty wrzuciem. 
na moim silniku dalej ten sam problem.
na silniku, który podales w linku jest taki problem: 

https://zapodaj.net/a6c41fa22f23c.png.html

Serio ja juz nie mam pojecia dlaczego u mnie nie idzie zadna kompilacja.
jest to swiezo zainstalowany system i zainstalowane wtyczki tylko te ktore ty podales. 
jakies pomysly? ewentualnie moge nawet dac dane do tego vps i mozesz sam to obczaic, bo ja juz klekam;/
Odpowiedz
#8

Okej uporalem sie z tym inaczej...
Teraz mam problem z baza danych wyskakuje blad przy wrzucaniu pliku schema. Cos tam ze jest za dluga jutro moge wrzucic blad. Z czego korzystacie aby mieć phpmyadmin? Standardowo z repetytorium linuxa xzy moze cos typu xampp?
Odpowiedz
#9

Schema weź sobie skopiuj zawartość i wrzuć w dziale ots w sql Smile

Nie wrzucaj ręcznie Smile

No dobra kompilacja ukończona. I jak go teraz włączyć? :]
Odpowiedz
#10

Wrzucilem recznie ale zmienilem pare opcji w tabeli i przeszlo. 
Temat do zamkniecia
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości