Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5

#11

Dobra teraz mam tak

<movevent type="StepIn" itemid="9055" event="script" value="sqm.lua"/>

local outfitId = 1 -- fill this with desired outfit id
local addon = 3 -- i don't remember how it works, but probably 0,1,2,3 are possible values
function onStepIn(cid, item, position, fromPosition)
if item.actionid == 7997 then
if canPlayerWearOutfitId(cid, outfitId, addon) then
return true
end
return false
end

9055 to id kratki

31/07/2020 20:04:21] [Error - LuaScriptInterface::loadFile] data/movements/scripts/sqm.lua:9: 'end' expected (to close 'function' at line 3) near '<eof>'
[31/07/2020 20:04:21] [Warning - Event::loadScript] Cannot load script (data/movements/scripts/sqm.lua)
[31/07/2020 20:04:21] data/movements/scripts/sqm.lua:9: 'end' expected (to close 'function' at line 3) near '<eof>'

Lece do pracy jutro dalej haha xD Dzieki ze mi pomagasz Tongue
Odpowiedz
#12

kamyczek ogladales to moze ? xd
Odpowiedz
#13

return false
end
wywal to.
Odpowiedz
#14

local outfitId = 1 -- fill this with desired outfit id
local addon = 3 -- i don't remember how it works, but probably 0,1,2,3 are possible values
function onStepIn(cid, item, position, fromPosition)
if item.actionid == 7997 then
if canPlayerWearOutfitId(cid, outfitId, addon) then
return true
end

dalej bład
01/08/2020 17:41:36] [Error - LuaScriptInterface::loadFile] data/movements/scripts/sqm.lua:7: 'end' expected (to close 'if' at line 4) near '<eof>'
[01/08/2020 17:41:36] [Warning - Event::loadScript] Cannot load script (data/movements/scripts/sqm.lua)
[01/08/2020 17:41:36] data/movements/scripts/sqm.lua:7: 'end' expected (to close 'if' at line 4) near '<eof>'
Odpowiedz
#15

Kurcze ciezko to ogarnac ;/
Odpowiedz
#16

Jeśli już gdzieś masz taki skrypt na serwerze tzn był tam to po prostu ctrl c ctrl v Wink

[Obrazek: virtualmt21587022115__sygnaturka_feru_net.png]
Odpowiedz
#17

Własnie nie ma ;/
I tu jest problem xd
Odpowiedz
#18

(08-02-2020, 08:39 AM)matt987 napisał(a):  Własnie nie ma ;/
I tu jest problem xd
Nwm czy funkcji tam nie musisz wrzucic local function (stepin itp
+ blad masz opisany w bledzie Big Grin gdzies musisz zamknac skrypt dodac end
Odpowiedz
#19

Aha rozwiazanie proste bylo XD teraz se postawilem 8.6 i z ciekawosci sprawdzilem to co mowisz wystarczy dodac funkcje cofniecia bo skrypt dziala lecz jezeli nie masz danego outfitu to nic sie nie dzieje Smile

local outfitId = 1
local addon = 3
function onStepIn(cid, item, position, fromPosition)
if canPlayerWearOutfitId(cid, outfitId, addon) then
return true
end
doTeleportThing(cid, fromPosition)
doPlayerSendCancel(cid, 'You need full citizen addon')
return false
end

Prosze bardzo dziala perfekto Tongue, dodalem jeszcze ze informuje nas o tym ze musimy miec outfit wiadomo ze trzeba go zmienic wedle upodoban XD
Odpowiedz
#20

Kamyk jestes wielki ! Smile
Bardzo dziekuje Wink
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości